Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 25
  1. #11

    Join Date
    December 19th, 2008
    Posts
    9
    Just installed latest version (6.1.16452) and still having the same error, despite the many fixes listed on http://zygorguides.com/archive/ to the AH tools

  2. #12

    Join Date
    December 19th, 2008
    Posts
    9
    Oooh, I think I just figured out where the "bug" actually lies. It has to to do with the "Price per: unit/stack" radio buttons... the bug only seems to appear when the "stack" option is selected.

    If "unit" is selected, everything acts like it did before.

  3. #13
    Administrator Zygor Support's Avatar
    Join Date
    October 24th, 2008
    Posts
    10,971
    We'll have to investigate that more. That is with today's update? Could you post the error you see when it's set to stack?
    Become a Fan of Zygor Guides on Facebook:
    http://www.facebook.com/pages/Zygor-...04933799556988

    Follow Zygor Guides on Twitter:
    http://twitter.com/zygorguides

  4. #14

    Join Date
    December 19th, 2008
    Posts
    9
    Quote Originally Posted by Zygor Support View Post
    That is with today's update?
    Yes

    Quote Originally Posted by Zygor Support View Post
    Could you post the error you see when it's set to stack?
    Same error that's been reported:

    11x ...ddOns\ZygorGuidesViewer\GoldUI\Auctiontools-Sell.lua:653: attempt to perform arithmetic on local 'countForSellCalc' (a nil value)

  5. #15
    I see the line numbers are different for my error report.
    Code:
    Message: ...ddOns\ZygorGuidesViewer\GoldUI\Auctiontools-Sell.lua:702: attempt to perform arithmetic on local 'countForSellCalc' (a nil value)
    Time: 08/12/17 14:46:18
    Count: 1
    Stack: ...ddOns\ZygorGuidesViewer\GoldUI\Auctiontools-Sell.lua:702: attempt to perform arithmetic on local 'countForSellCalc' (a nil value)Interface\SharedXML\SharedBasicControls.lua:204: in function <Interface\SharedXML\SharedBasicControls.lua:203>
    [C]: ?
    ...ddOns\ZygorGuidesViewer\GoldUI\Auctiontools-Sell.lua:702: in function `SetSellHistoricalLabels'
    ...ddOns\ZygorGuidesViewer\GoldUI\Auctiontools-Sell.lua:441: in function `ActivateSellItem'
    ...ddOns\ZygorGuidesViewer\GoldUI\Auctiontools-Sell.lua:943: in function `SelectShoppingRow'
    ...ddOns\ZygorGuidesViewer\GoldUI\Auctiontools-Sell.lua:323: in function `RefreshSellingItem'
    ...ddOns\ZygorGuidesViewer\GoldUI\Auctiontools-Core.lua:154: in function `Update'
    ...ddOns\ZygorGuidesViewer\GoldUI\Auctiontools-View.lua:1361: in function `SetCurrentTab'
    ...ddOns\ZygorGuidesViewer\GoldUI\Auctiontools-View.lua:1610: in function `OnZygorTabClick'
    ...ddOns\ZygorGuidesViewer\GoldUI\Auctiontools-View.lua:1635: in function <...ddOns\ZygorGuidesViewer\GoldUI\Auctiontools-View.lua:1632>
    ...s\ZygorGuidesViewer\Libs\AceHook-3.0\AceHook-3.0.lua:92: in function `AuctionFrameTab_OnClick'
    [string "*:OnClick"]:1: in function <[string "*:OnClick"]:1>
    [C]: in function `Click'
    ...ddOns\ZygorGuidesViewer\GoldUI\Auctiontools-View.lua:1339: in function `ActivateTab'
    ...ddOns\ZygorGuidesViewer\GoldUI\Auctiontools-View.lua:1380: in function `ShowWindow'
    ...ddOns\ZygorGuidesViewer\GoldUI\Auctiontools-Core.lua:761: in function <...ddOns\ZygorGuidesViewer\GoldUI\Auctiontools-Core.lua:754>
    
    Locals: errorMessage = "...ddOns\ZygorGuidesViewer\GoldUI\Auctiontools-Sell.lua:702: attempt to perform arithmetic on local 'countForSellCalc' (a nil value)"
    DisplayMessageInternal = <function> defined @Interface\SharedXML\SharedBasicControls.lua:187
    MESSAGE_TYPE_ERROR = 0
    A volunteer Curse Moderator. I write some AddOns too.

    Hey, check me out on Twitch.tv! I will soon have videos on YouTube.

  6. #16
    Administrator Zygor Support's Avatar
    Join Date
    October 24th, 2008
    Posts
    10,971
    It looks like they're still working on it with testing so not sure what those fixes that went out were supposed to address.
    Become a Fan of Zygor Guides on Facebook:
    http://www.facebook.com/pages/Zygor-...04933799556988

    Follow Zygor Guides on Twitter:
    http://twitter.com/zygorguides

  7. #17

    Join Date
    December 19th, 2008
    Posts
    9
    Yes, the line numbers have changed, but this error is the same. I simply c&p'd the original error from the beginning of the thread cause I was lazy.

    This is the verbiage that's showing up for me now:

    Code:
    Message: ...ddOns\ZygorGuidesViewer\GoldUI\Auctiontools-Sell.lua:702: attempt to perform arithmetic on local 'countForSellCalc' (a nil value)
    Time: Sun Aug 13 11:29:35 2017
    Count: 2
    Stack: ...ddOns\ZygorGuidesViewer\GoldUI\Auctiontools-Sell.lua:702: attempt to perform arithmetic on local 'countForSellCalc' (a nil value)Interface\SharedXML\SharedBasicControls.lua:189: in function <Interface\SharedXML\SharedBasicControls.lua:187>
    Interface\SharedXML\SharedBasicControls.lua:204: in function <Interface\SharedXML\SharedBasicControls.lua:203>
    [C]: ?
    ...ddOns\ZygorGuidesViewer\GoldUI\Auctiontools-Sell.lua:702: in function `SetSellHistoricalLabels'
    ...ddOns\ZygorGuidesViewer\GoldUI\Auctiontools-Sell.lua:441: in function `ActivateSellItem'
    ...ddOns\ZygorGuidesViewer\GoldUI\Auctiontools-View.lua:343: in function <...ddOns\ZygorGuidesViewer\GoldUI\Auctiontools-View.lua:341>
    
    Locals: errorTypeCVar = "scriptErrors"
    warnType = false
    msg = "...ddOns\ZygorGuidesViewer\GoldUI\Auctiontools-Sell.lua:702: attempt to perform arithmetic on local 'countForSellCalc' (a nil value)"
    messageType = 0
    hideErrorFrame = false
    IsErrorCVarEnabled = <function> defined @Interface\SharedXML\SharedBasicControls.lua:183
    I can confirm that the error only shows up when the "Stack" option is selected, not "Unit" (I've been able to use this one without a problem):
    zygor-ah-error.png

  8. #18

    Join Date
    December 19th, 2008
    Posts
    9
    I can confirm that today's release (6.1.16482) has fixed this issue.

    Thank you!

  9. #19

    Join Date
    October 5th, 2012
    Posts
    21
    Quote Originally Posted by tdometech View Post
    I can confirm that today's release (6.1.16482) has fixed this issue.

    Thank you!
    Still happens for me that version, tracked it down to Battle Pets, when those are selected it spews out the LUA errors.
    Code:
    Message: ...ddOns\ZygorGuidesViewer\GoldUI\Auctiontools-Core.lua:1022: bad argument #4 to 'format' (string expected, got nil)
    Time: 08/17/17 05:48:29
    Count: 81
    Stack: ...ddOns\ZygorGuidesViewer\GoldUI\Auctiontools-Core.lua:1022: bad argument #4 to 'format' (string expected, got nil)Interface\SharedXML\SharedBasicControls.lua:204: in function <Interface\SharedXML\SharedBasicControls.lua:203>
    [C]: ?
    [C]: in function `format'
    ...ddOns\ZygorGuidesViewer\GoldUI\Auctiontools-Core.lua:1022: in function <...ddOns\ZygorGuidesViewer\GoldUI\Auctiontools-Core.lua:926>
    
    Locals: errorMessage = "...ddOns\ZygorGuidesViewer\GoldUI\Auctiontools-Core.lua:1022: bad argument #4 to 'format' (string expected, got nil)"
    DisplayMessageInternal = <function> defined @Interface\SharedXML\SharedBasicControls.lua:187
    MESSAGE_TYPE_ERROR = 0

  10. #20

    Join Date
    December 19th, 2008
    Posts
    9
    That is an entirely different error/bug... and has nothing to do with the errors related to this thread...

Page 2 of 3 FirstFirst 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •