Page 1 of 2 12 LastLast
Results 1 to 10 of 11
  1. #1
    trial user
    Join Date
    May 7th, 2016
    Posts
    2

    Creating multiple items with Jewelcrafting, Jeweler's Kit bug

    When i'm Creating multiple items for levling my Jewelcrafting i get the error that i don't have Jeweler's Kit, but i do.

    I have tried disable all addons expect zygor, didn't help,
    but if i disable zygor i don't get this bug

  2. #2
    Administrator Zygor Support's Avatar
    Join Date
    October 24th, 2008
    Posts
    10,882
    Do you get any LUA errors? Try doing a full guide wipe/reset.

    1. exit WoW
    2. go to the WoW/Interface/Addons folder and delete the ZygorGuidesViewer folder
    3. go to the WoW/WTF/Account/<accountname>/SavedVariables folder and delete the Zygor files in there
    4. run the desktop client and install a fresh copy of the guides
    5. go back in game to test and let me know if that fixed it
    Become a Fan of Zygor Guides on Facebook:
    http://www.facebook.com/pages/Zygor-...04933799556988

    Follow Zygor Guides on Twitter:
    http://twitter.com/zygorguides

  3. #3
    trial user
    Join Date
    May 7th, 2016
    Posts
    2
    I tried it now, and it didn't fix it :/

  4. #4
    Administrator Zygor Support's Avatar
    Join Date
    October 24th, 2008
    Posts
    10,882
    Try this slightly different test. This will make everything act as if it was installed for the first time and will make it so that Zygor is the only addon you ever installed. Once the test is done you'll be able to get everything back to normal by renaming the folders back to original.


    1. Exit the game
    2. Go to your WoW/Cache folder and delete everything in there
    3. Go to your WoW folder and rename the Interface and WTF folders to Interface.Old and WTF.Old
    4. Run the Zygor desktop client, click the refresh button in the top right, and then click on the Install button
    5. Go in game to test and then let me know if that fixed it
    Become a Fan of Zygor Guides on Facebook:
    http://www.facebook.com/pages/Zygor-...04933799556988

    Follow Zygor Guides on Twitter:
    http://twitter.com/zygorguides

  5. #5

    Join Date
    August 9th, 2016
    Posts
    3
    I disabled zygors and the problem fixed itself, enabled Zygors and the problem returned. If you open the jewelcrafting windows you can see the jewelcrafting kit moving from white to red and back again.

  6. #6
    Administrator Zygor Support's Avatar
    Join Date
    October 24th, 2008
    Posts
    10,882
    This is something we are looking into to solve.
    Become a Fan of Zygor Guides on Facebook:
    http://www.facebook.com/pages/Zygor-...04933799556988

    Follow Zygor Guides on Twitter:
    http://twitter.com/zygorguides

  7. #7

    Join Date
    August 9th, 2016
    Posts
    3
    Any update on a fix, this is incredibly annoying as it screws up bag inventory also causing the bags to constantly try and update especially when a new item is received or created.

  8. #8

    Join Date
    November 11th, 2017
    Posts
    1
    Blacksmithing has the same problem just with the blacksmith hammer.

  9. #9
    Administrator Zygor Dev 1's Avatar
    Join Date
    December 1st, 2008
    Posts
    414
    We've had quite a lot on our hands lately, so this bug had to be postponed - sorry about this taking so long.

    The good news is that we found what's wrong. Now, fixing it will be another matter entirely - Blizzard made certain changes to the Tradeskills that aren't making our lives easier at all.

    (For those into specifics: every time Zygor Guides checks what crafting recipes you know - and it does every few seconds, just in case - the game now ends up forgetting the specifics of the currently shown recipe, so it takes a few seconds for it to ask the game server for it.)

    For those affected by this bug, today I can offer a band-aid solution. Run the following command:
    Code:
    /run ZGV.CacheRecipes_Queued=function() end
    It will fix the default crafting interface for this session - but, as a nasty side effect, it'll disable Zygor Guides' ability to detect what crafting recipes you have learned. Your Profession and Gold - Crafting guides will be flying blind.

    Rest assured, however, that we're working on a proper fix - stay tuned!

  10. #10

    Join Date
    June 21st, 2015
    Posts
    2
    I know this is an old thread, but, I am having issues whenever I log in with ZYGOR stealing the memory and I lag for like 30-45 seconds. I cannot do anything until ZYGOR fully loads. I understand that there are 'alot' of guides that need to load, but, this problem almost never happened until recently [WoW Legion 7.3] In addition, when I open any of my crafting on any of my toons, ZYGOR again steals the memory, and I cannot craft for 30 seconds or more. Seems to be some type of memory leak. Any fix's for this?

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •