Results 1 to 3 of 3

Thread: Bug report

  1. #1
    trial user
    Join Date
    February 6th, 2018
    Posts
    2

    Bug report

    New here and could not find where to report bug. But keep getting this error
    Message: ...rface\AddOns\ZygorGuidesViewer\ZygorGuidesViewe r.lua:871: ERROR in startup frame 58: Interface\AddOns\ZygorGuidesViewer\ActionBar.lua:1 15: ActionButton must have data defined if type is set
    in
    [C]: in function `error'
    Interface\AddOns\ZygorGuidesViewer\ActionBar.lua:1 15: in function `SetButton'
    ...rface\AddOns\ZygorGuidesViewer\ZygorGuidesViewe r.lua:1429: in function `SetActionButtons'
    ...rface\AddOns\ZygorGuidesViewer\ZygorGuidesViewe r.lua:1387: in function `FocusStep'
    ...rface\AddOns\ZygorGuidesViewer\ZygorGuidesViewe r.lua:1147: in function `SetGuide'
    ...rface\AddOns\ZygorGuidesViewer\ZygorGuidesViewe r.lua:972: in function `LoadInitialGuide'
    ...rface\AddOns\ZygorGuidesViewer\ZygorGuidesViewe r.lua:471: in function `Startup_LoadGuides_Threaded'
    ...rface\AddOns\ZygorGuidesViewer\ZygorGuidesViewe r.lua:729: in function <...rface\AddOns\ZygorGuidesViewer\ZygorGuidesView er.lua:644>

    Time: 02/12/18 13:56:45
    Count: 1
    Stack: ...rface\AddOns\ZygorGuidesViewer\ZygorGuidesViewe r.lua:871: ERROR in startup frame 58: Interface\AddOns\ZygorGuidesViewer\ActionBar.lua:1 15: ActionButton must have data defined if type is set
    in
    [C]: in function `error'
    Interface\AddOns\ZygorGuidesViewer\ActionBar.lua:1 15: in function `SetButton'
    ...rface\AddOns\ZygorGuidesViewer\ZygorGuidesViewe r.lua:1429: in function `SetActionButtons'
    ...rface\AddOns\ZygorGuidesViewer\ZygorGuidesViewe r.lua:1387: in function `FocusStep'
    ...rface\AddOns\ZygorGuidesViewer\ZygorGuidesViewe r.lua:1147: in function `SetGuide'
    ...rface\AddOns\ZygorGuidesViewer\ZygorGuidesViewe r.lua:972: in function `LoadInitialGuide'
    ...rface\AddOns\ZygorGuidesViewer\ZygorGuidesViewe r.lua:471: in function `Startup_LoadGuides_Threaded'
    ...rface\AddOns\ZygorGuidesViewer\ZygorGuidesViewe r.lua:729: in function <...rface\AddOns\ZygorGuidesViewer\ZygorGuidesView er.lua:644>

    Interface\SharedXML\SharedBasicControls.lua:208: in function <Interface\SharedXML\SharedBasicControls.lua:207 >
    [C]: ?
    [C]: in function `error'
    ...rface\AddOns\ZygorGuidesViewer\ZygorGuidesViewe r.lua:871: in function `StartupStep'
    Interface\AddOns\ZygorGuidesViewer\MasterFrame.lua :6: in function <Interface\AddOns\ZygorGuidesViewer\MasterFrame.lu a:4>

    Locals: errorMessage = "...rface\AddOns\ZygorGuidesViewer\ZygorGuidesView er.lua:871: ERROR in startup frame 58: Interface\AddOns\ZygorGuidesViewer\ActionBar.lua:1 15: ActionButton must have data defined if type is set
    in
    [C]: in function `error'
    Interface\AddOns\ZygorGuidesViewer\ActionBar.lua:1 15: in function `SetButton'
    ...rface\AddOns\ZygorGuidesViewer\ZygorGuidesViewe r.lua:1429: in function `SetActionButtons'
    ...rface\AddOns\ZygorGuidesViewer\ZygorGuidesViewe r.lua:1387: in function `FocusStep'
    ...rface\AddOns\ZygorGuidesViewer\ZygorGuidesViewe r.lua:1147: in function `SetGuide'
    ...rface\AddOns\ZygorGuidesViewer\ZygorGuidesViewe r.lua:972: in function `LoadInitialGuide'
    ...rface\AddOns\ZygorGuidesViewer\ZygorGuidesViewe r.lua:471: in function `Startup_LoadGuides_Threaded'
    ...rface\AddOns\ZygorGuidesViewer\ZygorGuidesViewe r.lua:729: in function <...rface\AddOns\ZygorGuidesViewer\ZygorGuidesView er.lua:644>
    "
    DisplayMessageInternal = <function> defined @Interface\SharedXML\SharedBasicControls.lua:191
    MESSAGE_TYPE_ERROR = 0
    Message: Interface\AddOns\ZygorGuidesViewer\ActionBar.lua:1 15: ActionButton must have data defined if type is set
    Time: 02/12/18 14:05:13
    Count: 3
    Stack: Interface\AddOns\ZygorGuidesViewer\ActionBar.lua:1 15: ActionButton must have data defined if type is set
    Interface\SharedXML\SharedBasicControls.lua:208: in function <Interface\SharedXML\SharedBasicControls.lua:207 >
    (tail call): ?
    [C]: in function `error'
    Interface\AddOns\ZygorGuidesViewer\ActionBar.lua:1 15: in function `SetButton'
    ...rface\AddOns\ZygorGuidesViewer\ZygorGuidesViewe r.lua:1429: in function `SetActionButtons'
    ...rface\AddOns\ZygorGuidesViewer\ZygorGuidesViewe r.lua:3848: in function `func'
    ...rface\AddOns\ZygorGuidesViewer\ZygorGuidesViewe r.lua:948: in function `?'
    ...Ons\Ace3\CallbackHandler-1.0\CallbackHandler-1.0.lua:145: in function <...Ons\Ace3\CallbackHandler-1.0\CallbackHandler-1.0.lua:145>
    [string "safecall Dispatcher[1]"]:4: in function <[string "safecall Dispatcher[1]"]:4>
    [C]: ?
    [string "safecall Dispatcher[1]"]:13: in function `?'
    ...Ons\Ace3\CallbackHandler-1.0\CallbackHandler-1.0.lua:90: in function `Fire'
    Interface\AddOns\Ace3\AceEvent-3.0\AceEvent-3.0.lua:120: in function <Interface\AddOns\Ace3\AceEvent-3.0\AceEvent-3.0.lua:119>

    Locals: <none>

  2. #2
    Administrator Zygor Support's Avatar
    Join Date
    October 24th, 2008
    Posts
    11,542
    Try doing a full guide wipe/reset.


    1. exit WoW
    2. go to the WoW/Interface/Addons folder and delete the ZygorGuidesViewer folder
    3. go to the WoW/WTF/Account/<accountname>/SavedVariables folder and delete the Zygor files in there
    4. run the desktop client and install a fresh copy of the guides
    5. go back in game to test and let me know if that fixed it
    Become a Fan of Zygor Guides on Facebook:
    http://www.facebook.com/pages/Zygor-...04933799556988

    Follow Zygor Guides on Twitter:
    http://twitter.com/zygorguides

  3. #3
    trial user
    Join Date
    February 6th, 2018
    Posts
    2
    Have not done that yet, but after completing the quest that started it i have no encountered the issue again. But i will do that just to be safe. Thanks.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •