Results 1 to 8 of 8

Thread: Error

  1. #1

    Join Date
    January 1st, 2011
    Posts
    1

    Angry Error

    So I had to completely turn off my guide for now because of this. This is very disappointing, any fix?

    Error during initialization sequence 'ItemScore':
    ...nterface\AddOns\ZygorGuidesViewer\Item-ItemScore.lua:134: bad argument #1 to 'pairs' (table expected, got nil)
    -- STACKTRACE: --
    [C]: ?
    [ZGV]\Item-ItemScore.lua:134: in function `SetStatWeights'
    [ZGV]\Item-ItemScore.lua:108: in function `RefreshUserData'
    [ZGV]\Item-ItemScore.lua:71: in function `Initialise'
    [ZGV]\Item-ItemScore.lua:798: in function `func'
    [ZGV]\ZygorGuidesViewer.lua:689: in function <[ZGV]\ZygorGuidesViewer.lua:689>

  2. #2
    Administrator Zygor Support's Avatar
    Join Date
    October 24th, 2008
    Posts
    12,474
    Been helping you in emails.
    Become a Fan of Zygor Guides on Facebook:
    http://www.facebook.com/pages/Zygor-...04933799556988

    Follow Zygor Guides on Twitter:
    http://twitter.com/zygorguides

  3. #3

    Join Date
    December 20th, 2009
    Posts
    4
    i'm also getting errors

    On load up
    Message: Error during initialization sequence 'ItemScore':
    Interface\AddOns\ZygorGuidesViewer\Item-Upgrades.lua:512: attempt to compare number with nil
    -- STACKTRACE: --
    [ZGV]\Item-Upgrades.lua:512: in function `ProcessWeaponQueue'
    [ZGV]\Item-Upgrades.lua:596: in function `ScanBagsForUpgrades'
    [ZGV]\Item-ItemScore.lua:110: in function `RefreshUserData'
    [ZGV]\Item-ItemScore.lua:71: in function `Initialise'
    [ZGV]\Item-ItemScore.lua:798: in function `func'
    [ZGV]\ZygorGuidesViewer.lua:689: in function <[ZGV]\ZygorGuidesViewer.lua:689>

    Time: Tue Oct 9 10:52:54 2018
    Count: 1
    Stack: Error during initialization sequence 'ItemScore':
    Interface\AddOns\ZygorGuidesViewer\Item-Upgrades.lua:512: attempt to compare number with nil
    -- STACKTRACE: --
    [ZGV]\Item-Upgrades.lua:512: in function `ProcessWeaponQueue'
    [ZGV]\Item-Upgrades.lua:596: in function `ScanBagsForUpgrades'
    [ZGV]\Item-ItemScore.lua:110: in function `RefreshUserData'
    [ZGV]\Item-ItemScore.lua:71: in function `Initialise'
    [ZGV]\Item-ItemScore.lua:798: in function `func'
    [ZGV]\ZygorGuidesViewer.lua:689: in function <[ZGV]\ZygorGuidesViewer.lua:689>

    ...rface\AddOns\ZygorGuidesViewer\ZygorGuidesViewe r.lua:641: in function `StartupModule_Threaded'
    ...rface\AddOns\ZygorGuidesViewer\ZygorGuidesViewe r.lua:691: in function <...rface\AddOns\ZygorGuidesViewer\ZygorGuidesView er.lua:655>

    Locals: <none>

    This is popping up constantly making it impossible to use addon
    Last edited by faulkcolin; 1 Week Ago at 05:00 AM.

  4. #4
    Administrator Zygor Support's Avatar
    Join Date
    October 24th, 2008
    Posts
    12,474
    Try again with the update we sent out today to see if it's fixed now.
    Become a Fan of Zygor Guides on Facebook:
    http://www.facebook.com/pages/Zygor-...04933799556988

    Follow Zygor Guides on Twitter:
    http://twitter.com/zygorguides

  5. #5

    Join Date
    October 24th, 2014
    Posts
    4
    I'm not getting LUA errors now but when I tell the guide NO, it doesn't go away. It repeatedly keeps trying to suggest the same thing

  6. #6
    Administrator Zygor Support's Avatar
    Join Date
    October 24th, 2008
    Posts
    12,474
    Try doing a full guide wipe/reset.

    1. exit WoW
    2. go to the WoW/Interface/Addons folder and delete the ZygorGuidesViewer folder
    3. go to the WoW/WTF/Account/<accountname>/SavedVariables folder and delete the Zygor files in there
    4. run the desktop client and install a fresh copy of the guides
    5. go back in game to test and let me know if that fixed it
    Become a Fan of Zygor Guides on Facebook:
    http://www.facebook.com/pages/Zygor-...04933799556988

    Follow Zygor Guides on Twitter:
    http://twitter.com/zygorguides

  7. #7

    Join Date
    March 23rd, 2010
    Posts
    20
    Having the same issue over here. Makes the guide very unappealing.

  8. #8

    Join Date
    October 24th, 2014
    Posts
    4
    I just got back around to tell you, that did not work. I hit no and it just keeps suggesting the same thing. I turned it off.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •