PDA

View Full Version : Disabling Talent Advisor



MrSapient
November 20th, 2014, 11:52 AM
Happens every time i disable the talent advisor .. no other addons


Message: Interface\AddOns\ZygorGuidesViewer\Options.lua:136 4: attempt to call global 'ResetAllTalentIcons' (a nil value)
Time: 11/20/14 11:51:07
Count: 1
Stack: Interface\AddOns\ZygorGuidesViewer\Options.lua:136 4: in function <Interface\AddOns\ZygorGuidesViewer\Options.lua:135 3>
(tail call): ?
[C]: ?
[string "safecall Dispatcher[2]"]:9: in function <[string "safecall Dispatcher[2]"]:5>
(tail call): ?
...nfig-3.0\AceConfigDialog-3.0\AceConfigDialog-3.0.lua:799: in function <...nfig-3.0\AceConfigDialog-3.0\AceConfigDialog-3.0.lua:614>
(tail call): ?
[C]: ?
[string "safecall Dispatcher[3]"]:9: in function <[string "safecall Dispatcher[3]"]:5>
(tail call): ?
...Ons\ZygorGuidesViewer\Libs\AceGUI-3.0\AceGUI-3.0.lua:314: in function `Fire'
...er\Libs\AceGUI-3.0\widgets\AceGUIWidget-CheckBox.lua:68: in function <...er\Libs\AceGUI-3.0\widgets\AceGUIWidget-CheckBox.lua:57>

Locals: <none>

ZG Support 1
November 20th, 2014, 12:42 PM
Added to our list to be looked into.

7ba2fa02
September 7th, 2016, 04:09 PM
When disabling the Talent Advisor I get:



Message: Interface\AddOns\ZygorGuidesViewer\TalentAdvisor.l ua:217: bad argument #1 to 'pairs' (table expected, got nil)
Time: 09/07/16 16:05:33
Count: 1
Stack: (tail call): ?
[C]: in function `pairs'
Interface\AddOns\ZygorGuidesViewer\TalentAdvisor.l ua:217: in function `Toggle'
Interface\AddOns\ZygorGuidesViewer\Options.lua:172 7: in function <Interface\AddOns\ZygorGuidesViewer\Options.lua:172 5>
(tail call): ?
[C]: ?
[string "safecall Dispatcher[2]"]:9: in function <[string "safecall Dispatcher[2]"]:5>
(tail call): ?
...nfig-3.0\AceConfigDialog-3.0\AceConfigDialog-3.0.lua:799: in function <...nfig-3.0\AceConfigDialog-3.0\AceConfigDialog-3.0.lua:614>
(tail call): ?
[C]: ?
[string "safecall Dispatcher[3]"]:9: in function <[string "safecall Dispatcher[3]"]:5>
(tail call): ?
...face\AddOns\Altoholic\libs\AceGUI-3.0\AceGUI-3.0.lua:314: in function `Fire'
...er\Libs\AceGUI-3.0\widgets\AceGUIWidget-CheckBox.lua:68: in function <...er\Libs\AceGUI-3.0\widgets\AceGUIWidget-CheckBox.lua:57>

Locals: <none>


This is after deleting and installing Zygor and my saved variables.

ZG Support 1
September 7th, 2016, 06:37 PM
Do you get the same error if you disable all other addons?