View Full Version : Battle Pet Tamers: Eastern Kingdoms

June 9th, 2019, 06:13 AM
The guide viewer won't register that I have this quest (as I never did unlock dailies for battle pets, only just now back after a few year absence). If I mark the accepting portion as complete, it zooms through all of the battles as if I've completed them as well; if I backtrack manually, the 'defeat' steps are greyed out. It does at least allow me to manually advance through to find them but it's not working as intended since it thinks I've finished the quest (I haven't).

ZG Support 1
June 9th, 2019, 02:32 PM
Alliance or Horde? Did you try loading the guide back at step 1 to make sure nothing was missed?

June 10th, 2019, 12:39 PM
Horde, and yep. I ended up finishing them manually today, and I reloaded, went to the beginning, and clicked the blue arrow to start the guide to beat the grand master trainers. It went through all of Kalimdor fine, then tried to get me to accept Battle Pet Tamers: Eastern Kingdoms again, despite me having finished that questline minutes before.

ZG Support 2
June 10th, 2019, 01:15 PM
Please try the following and see if it resolves the issue:

1. Exit out of the game completely.
2. Open the Zygor Guides Client. Click on "WoW Guide Content" to select it, then click the Repair button.
3. When it finishes repairing, go back in the game and see if the issue is resolved.

June 11th, 2019, 05:21 AM
Nope. Now it has shifted back and has me on "Accept 'Battle Pet Tamers: Eastern Kingdoms" but isn't advancing. You can see here where I've beaten Lydia today, I have the daily for the Kalimdor side open as well, and I've accepted the Outland quest. It's just not advancing forward / won't register that I've beaten that quest.


If it helps, I couldn't actually see the battle pet quest initially on this character? He's a boosted DK. I took the quests on my lower level priest, then hopped over to the DK to actually do them. There was 0 problem doing the Kalimdor side, then this started when I hit EK.


Out of curiosity I went over to THAT toon, and it sticks on the same spot. Varzok has nothing for me since I already did EK and shows only the pvp quest which I haven't done yet.


Edit 2: I went ahead and loaded Outland, which worked fine. When I was given Northrend, however, it's doing the same thing as EK. It won't register that I've accepted Battle Pet Tamers: Northrend.

Edit 3: Nevermind, Northrend works fine, it's only EK. Possibly related though, I accepted the quest for Northrend on the toon that couldn't get the original ones, and it didn't 'register' to my account somehow. It popped, I hit accept, but it wasn't in my log. Went over to the other char, and it was available to accept. Switched back to the first, it was there, and Zy DID recognize it, so only EK not picking up right still.

Sorry for all the edits, just reporting the oddities as I play. lol

ZG Support 2
June 11th, 2019, 08:05 AM
Okay, I will create a ticket for a member of the team to look into this for you. Thank you for your support.