Log in to ZYGOR
Log in with social media
OR
Log in with Zygor account
Forgot your password?

Announcement

Collapse
No announcement yet.

Astrolabe

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Astrolabe

    I noticed upon logging in yesterday that Zygor is still attempting to use Astrolabe 3.0 library which has been obsolete for over a year now. This has been causing me to get Lua errors constantly every 1-2 seconds. Alot of my other addons have been updated to use the newer library called "HereBeDragons"

    I think this problem has been occurring since WoD, possibly since MoP.

    #2
    Please make sure you are using the latest version of the guide viewer. With the 6.0 version release we switched over to Dragons butt there are still a couple of items that will look to Astrolabe for some things. We used a custom version of Astrolabe so even tho it was discontinued a while ago we were keeping our version current for our needs.
    Become a Fan of Zygor Guides on Facebook:
    http://www.facebook.com/pages/Zygor-...04933799556988

    Follow Zygor Guides on Twitter:
    http://twitter.com/zygorguides

    Comment


      #3
      I'm on the latest update and I am being spammed by this...

      Comment


        #4
        Have you tried disabling all other addons to see if you still get the errors?
        Become a Fan of Zygor Guides on Facebook:
        http://www.facebook.com/pages/Zygor-...04933799556988

        Follow Zygor Guides on Twitter:
        http://twitter.com/zygorguides

        Comment


          #5
          bugsack is pointing at the viewer, and it gets 2-3 errors a second...

          58476x ...ddOns\ZygorGuidesViewer\Libs\Astrolabe\Astrolab e.lua:987: ...ddOns\ZygorGuidesViewer\Libs\Astrolabe\Astrolab e.lua:365: attempt to compare nil with number
          [C]: ?
          ...ddOns\ZygorGuidesViewer\Libs\Astrolabe\Astrolab e.lua:987: in function `CalculateMinimapIconPositions'
          ...ddOns\ZygorGuidesViewer\Libs\Astrolabe\Astrolab e.lua:886: in function `UpdateMinimapIconPositions'
          ...ddOns\ZygorGuidesViewer\Libs\Astrolabe\Astrolab e.lua:1145: in function `OnUpdate'
          ...ddOns\ZygorGuidesViewer\Libs\Astrolabe\Astrolab e.lua:1376: in function <...ddOns\ZygorGuidesViewer\Libs\Astrolabe\Astrola be.lua:1375>

          Locals:
          = <no value>
          Last edited by enzore_dax; October 27, 2016, 02:51 AM.

          Comment


            #6
            Have you tried disabling all other addons to see if you still get the errors?
            Become a Fan of Zygor Guides on Facebook:
            http://www.facebook.com/pages/Zygor-...04933799556988

            Follow Zygor Guides on Twitter:
            http://twitter.com/zygorguides

            Comment


              #7
              I had the same error, and thought to check if astrolabe was still part of the folder. it isn't.

              I think the main reason it shows up as a ZygorGuideViewer error, is that it uses the library if it's present or has been loaded because it's in the addons/libs folder of a different addon.

              obscure, but it's likely a legacy of being built on top of older zygor code.

              run a search, and delete the astrolabe folder/files, and any addons still using it, as I believe wow also loads addon files into memory, even if you disable the addon. hopefully i've gotten rid of enough addons to run dungeons without bugsack going off every 2 seconds...

              Comment


                #8
                Originally posted by toliman View Post
                I had the same error, and thought to check if astrolabe was still part of the folder. it isn't.

                I think the main reason it shows up as a ZygorGuideViewer error, is that it uses the library if it's present or has been loaded because it's in the addons/libs folder of a different addon.

                obscure, but it's likely a legacy of being built on top of older zygor code.

                run a search, and delete the astrolabe folder/files, and any addons still using it, as I believe wow also loads addon files into memory, even if you disable the addon. hopefully i've gotten rid of enough addons to run dungeons without bugsack going off every 2 seconds...
                Hmm, well the only Astrolabe I'm finding is in "C:\Program Files (x86)\World of Warcraft\interface\addons\ZygorGuidesViewer\Libs"

                I just ran a Darkbough and accumulated several thousand errors from Zygor's.

                45422x ...ddOns\ZygorGuidesViewer\Libs\Astrolabe\Astrolab e.lua:987: ...ddOns\ZygorGuidesViewer\Libs\Astrolabe\Astrolab e.lua:365: attempt to compare nil with number
                [C]: ?
                ...ddOns\ZygorGuidesViewer\Libs\Astrolabe\Astrolab e.lua:987: in function `CalculateMinimapIconPositions'
                ...ddOns\ZygorGuidesViewer\Libs\Astrolabe\Astrolab e.lua:1111: in function `OnEvent'
                ...ddOns\ZygorGuidesViewer\Libs\Astrolabe\Astrolab e.lua:1371: in function <...ddOns\ZygorGuidesViewer\Libs\Astrolabe\Astrola be.lua:1370>

                Locals:
                = <no value>

                Comment


                  #9
                  Have you tried reinstalling the guides?
                  Become a Fan of Zygor Guides on Facebook:
                  http://www.facebook.com/pages/Zygor-...04933799556988

                  Follow Zygor Guides on Twitter:
                  http://twitter.com/zygorguides

                  Comment


                    #10
                    I'm having trouble with this issue as well. It only happens when I'm inside a raid or dungeon instance.

                    I've tried a few variants of the usual solutions, and the results are a bit confusing:

                    1. Disabling all addons except Zygor (i.e. keeping my current settings) still results in the error. This would imply something's wrong in the Zygor settings.
                    2. Indeed, a totally fresh copy of Zygor running on its own (i.e. I deleted Interface and WTF, and hit refresh in the desktop client) results in no errors being produced.
                    3. However, running with my normal addons (and their settings intact), but having wiped the Zygor settings only (deleting "C:\Games\World of Warcraft\WTF\Account\XXXXXXX\SavedVariables\ZygorG uidesViewer.lua"), also results in the error. This would imply that its a compatibility issue with another addon.


                    I can only guess it's two issues then - something with my Zygor settings file, as well as an addon conflict. I'll try using a fresh copy of Zygor, and enabling my other addons slow to see if I can spot a conflict - but since its 0230 here, I'll do that tomorrow ;p.

                    Comment


                      #11
                      It could be a corrupted file somewhere in the WTF folder. Try running with your other addons going like normal but with a fresh WTF folder.
                      Become a Fan of Zygor Guides on Facebook:
                      http://www.facebook.com/pages/Zygor-...04933799556988

                      Follow Zygor Guides on Twitter:
                      http://twitter.com/zygorguides

                      Comment


                        #12
                        I tried doing that, but I still ran into the same issue.

                        There might have been an update overnight, but going back to basics seems to have fixed the issue.

                        I left my settings as they were, including Zygor's, but deleted the Zygor addon folder altogether and reinstalled it from the desktop utility. The Astrolabe library is now entirely gone, so if it wasn't an update then it must have been some artefacts left over from previous versions.

                        You mentioned before that some components were still using it. Could you clarify whether that's still the case in the latest version (6.0.14846 as of now)? Otherwise I'm slightly confused :P.

                        There were some other differences too. For example I had a separate folder "ZygorTalentAdvisor" which is now gone, and a number of files from the Skins folder are gone now too.

                        All dropped files are listed below:

                        Code:
                        \ZGV-20160902-legiontaxis.toc                    
                        \ZGV-20160906-shalaran.toc                        
                        \ZGV-content.toc                                  
                        \ZGV-goldguide.toc                                
                        \ZGV-legion.toc                                  
                        \ZGV-newgear.toc                                  
                        \ZGV-optimization.toc                            
                        \ZGV-scanlegion.toc                              
                        \ZygorGuidesViewer-BETA_.toc                      
                        \Guides\Leveling\DH_Starter_Alliance.lua          
                        \Guides\Leveling\DH_Starter_Horde.lua            
                        \Libs\Astrolabe\Astrolabe.lua                    
                        \Libs\Astrolabe\AstrolabeMapMonitor.lua          
                        \Libs\Astrolabe\DongleStub.lua                    
                        \Libs\Astrolabe\lgpl.txt                          
                        \Libs\Astrolabe\Load.xml                          
                        \Libs\Astrolabe\Microdungeons.lua                
                        \Skins\arrowdown.blp                              
                        \Skins\arrowup.blp                                
                        \Skins\backglass.blp                              
                        \Skins\ban.blp                                    
                        \Skins\blank.blp                                  
                        \Skins\config-images.blp                          
                        \Skins\glowborder.blp                            
                        \Skins\gnome.blp                                  
                        \Skins\gnome_back.blp                            
                        \Skins\goldguideicons.blp                        
                        \Skins\goldpricestatusicons.blp                  
                        \Skins\guideicons-small.blp                      
                        \Skins\icons-gold.blp                            
                        \Skins\icons-inventorymanager.blp                
                        \Skins\icons-notificationcenter.blp              
                        \Skins\leavesofsteel_border_flash.blp            
                        \Skins\leavesofsteel_top_flash.blp                
                        \Skins\levelbar.blp                              
                        \Skins\loading.blp                                
                        \Skins\minimaparrow-gold-dot.blp                  
                        \Skins\minimaparrow-gold-edge.blp                
                        \Skins\minimaparrow-green-edge.blp                
                        \Skins\newcheckoff.blp                            
                        \Skins\newcheckon.blp                            
                        \Skins\poirandomgreen.blp                        
                        \Skins\poi_icons.blp                              
                        \Skins\radiobutton-off.blp                        
                        \Skins\radiobutton-on.blp                        
                        \Skins\refresh.blp                                
                        \Skins\search.blp                                
                        \Skins\separator.blp                              
                        \Skins\SpeedIcon.blp                              
                        \Skins\tutorialline-dia.blp                      
                        \Skins\white.blp                                  
                        \Skins\white07.blp                                
                        \Skins\zglogo-back.blp                            
                        \Skins\zglogo.blp                                
                        \Skins\zglogo_single.blp                          
                        \Skins\zygorlogo.blp                              
                        \Skins\Default\Stealth\border-08.blp              
                        \Skins\Default\Stealth\border-glow.blp            
                        \Skins\Default\Stealth\border.blp                
                        \Skins\Default\Stealth\border_.blp                
                        \Skins\Default\Stealth\button.blp                
                        \Skins\Default\Stealth\corner.blp                
                        \Skins\Default\Stealth\guideicons-small.blp      
                        \Skins\Default\Stealth\mv-arrow.blp              
                        \Skins\Default\Stealth\scrollbutton.blp          
                        \Skins\Default\Stealth\selection.blp              
                        \Skins\Default\Stealth\stepicons.blp              
                        \Skins\Default\Stealth\titlebuttons.blp          
                        \Skins\Default\Stealth\zglogo_circ.blp            
                        \ZygorTalentAdvisor\Build.lua                    
                        \ZygorTalentAdvisor\Build_Data.lua                
                        \ZygorTalentAdvisor\Events.lua                    
                        \ZygorTalentAdvisor\files.xml                    
                        \ZygorTalentAdvisor\Popout.lua                    
                        \ZygorTalentAdvisor\Popout.xml                    
                        \ZygorTalentAdvisor\ZygorTalentAdvisor2.0.lua    
                        \ZygorTalentAdvisor\ZygorTalentAdvisorFiles.xml  
                        \ZygorTalentAdvisor\Builds\Autoload.xml          
                        \ZygorTalentAdvisor\Builds\ZygorGuidesBuilds.lua  
                        \ZygorTalentAdvisor\Skin\glowborder.tga          
                        \ZygorTalentAdvisor\Skin\mmbutton_off.tga        
                        \ZygorTalentAdvisor\Skin\mmbutton_on.tga          
                        \ZygorTalentAdvisor\Skin\mrripley_hints.tga      
                        \ZygorTalentAdvisor\Skin\popout-button-2-down.tga
                        \ZygorTalentAdvisor\Skin\popout-button-2-hi.tga  
                        \ZygorTalentAdvisor\Skin\popout-button-2.tga      
                        \ZygorTalentAdvisor\Skin\popout-button-pushed.tga
                        \ZygorTalentAdvisor\Skin\popout-button.tga        
                        \ZygorTalentAdvisor\Skin\popout-noclose.tga

                        I took a copy of the original addon folder, and used PowerShell to compare:

                        Code:
                        $LeftFolder = "C:\Games\World of Warcraft\Interface\AddOns\ZygorGuidesViewer"
                        $RightFolder = "C:\Users\XXXXX\Desktop\ZygorGuidesViewer"
                        $LeftSideHash = Get-ChildItem $LeftFolder -Recurse | Get-FileHash | select @{Label="Path";Expression={$_.Path.Replace($LeftFolder,"")}},Hash
                        $RightSideHash = Get-ChildItem $RightFolder -Recurse | Get-FileHash | select @{Label="Path";Expression={$_.Path.Replace($RightFolder,"")}},Hash
                        Compare-Object $LeftSideHash $RightSideHash -Property Path,Hash

                        Anyway, can someone else with the issue please try deleting the ZygorGuidesViewer from Interface/Addons, and reinstalling the guide from scratch using the client? Hopefully it will fix thing for other people too.

                        Comment


                          #13
                          Originally posted by Aspin View Post
                          Anyway, can someone else with the issue please try deleting the ZygorGuidesViewer from Interface/Addons, and reinstalling the guide from scratch using the client? Hopefully it will fix thing for other people too.
                          I had the same issue when entering instances too, thousands of Astrolabe errors. So I searched my Addons folder and deleted all references to Astrolabe (was a few in Eluvi and quest helper), I then deleted my Zygor Viewer folder.

                          After this I reinstalled Elvui, shadow & Light mod etc using the update option in the Tukui client. Once these were installed I then reinstalled Zygor from the reinstall option in the spanner icon. Once I logged back in, it appears to be working fine now.

                          Comment


                            #14
                            Astrolabe is no longer bundled with Zygor. However, the Zygor Desktop Client apparently isn't doing a "clean" upgrade between versions, ie: uninstalling old folders and installing fresh folders. There is legacy stuff left behind, including Astrolabe.

                            You shouldn't have to delete your saved variables, but certainly delete the ZygorGuidesView AddOn folder entirely, then reinstall via the client.
                            A volunteer Curse Moderator. I write some AddOns too.

                            https://www.youtube.com/user/myrroddin

                            Comment


                              #15
                              Originally posted by Aspin View Post
                              You mentioned before that some components were still using it. Could you clarify whether that's still the case in the latest version (6.0.14846 as of now)? Otherwise I'm slightly confused :P.
                              I thought that there were maybe one or two functions that still used it but apparently I was wrong. Sometimes it's good to be wrong.
                              Become a Fan of Zygor Guides on Facebook:
                              http://www.facebook.com/pages/Zygor-...04933799556988

                              Follow Zygor Guides on Twitter:
                              http://twitter.com/zygorguides

                              Comment

                              Working...
                              X