Log in to ZYGOR
Log in with social media
OR
Log in with Zygor account
Forgot your password?

Announcement

Collapse
No announcement yet.

Astrolabe

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Zygor Support
    replied
    The right click error should be fixed now. Please make sure to update the guides.

    Leave a comment:


  • Zygor Dev 1
    replied
    The "attempt to call a nil value ... in function `securecall'" was unrelated to Astrolabe, but it is now gone. Others are being investigated. Thanks for reporting and sorry for the trouble!

    Leave a comment:


  • Zygor Support
    replied
    I'll make sure one of our dev team sees this to investigate further.

    Leave a comment:


  • kupkakes11
    replied
    Still getting an error.
    Message: attempt to call a nil value
    Time: 10/28/16 21:25:36
    Count: 1
    Stack: [C]: in function `securecall'
    ...ace\AddOns\ZygorGuidesViewer\Libs\UIDropDownFor k.lua:64: in function `UIDropDownFork_Initialize'
    Interface\AddOns\ZygorGuidesViewer\Libs\EasyFork.l ua:21: in function `EasyFork'
    ...rface\AddOns\ZygorGuidesViewer\ZygorGuidesViewe r.lua:4508: in function `OpenQuickStepMenu'
    ...rface\AddOns\ZygorGuidesViewer\ZygorGuidesViewe r.lua:3960: in function `GoalOnClick'
    ...dOns\ZygorGuidesViewer\Skins\Default\ViewerFram e.lua:311: in function <...dOns\ZygorGuidesViewer\Skins\Default\ViewerFra me.lua:310>
    ...dOns\ZygorGuidesViewer\Skins\Default\ViewerFram e.lua:35: in function <...dOns\ZygorGuidesViewer\Skins\Default\ViewerFra me.lua:27>

    Locals: (*temporary) = <function> defined =[C]:-1
    (*temporary) = nil
    (*temporary) = ZGVF_Default_Menu {
    0 = <userdata>
    displayMode = "MENU"
    menuList = <table> {
    }
    goalframe = ZygorGuidesViewerFrame_Step1_Line2 {
    }
    Button = ZGVF_Default_MenuButton {
    }
    Text = ZGVF_Default_MenuText {
    }
    Icon = ZGVF_Default_MenuIcon {
    }
    stepframe = ZygorGuidesViewerFrame_Step1 {
    }
    }

    Leave a comment:


  • Zygor Support
    replied
    Astrolabe should not be getting added as an incremental update. The client uses the exact same file list when doing a full install and an update to determine what files should be in place.

    @kupkakes... Try this for a test.

    1. Exit the game
    2. Go to your WoW/Cache folder and delete everything in there
    3. Go to your WoW folder and rename the Interface and WTF folders to Interface.Old and WTF.Old
    4. Run the Zygor desktop client, click the refresh button in the top right, and then click on the Install button
    5. Go in game to test and then let me know if that fixed it

    This will make it act like the only addon ever installed was Zygor so see if that has any effect on the error you are seeing. By renaming those folders you'll be able to easily put your other addons and settings back in place if there is no change to the error.

    Leave a comment:


  • kupkakes11
    replied
    My libs folder doesnt have the Astrolabe folder, still receiving a LUA error. It happens when i click on a quest to skip a step.

    Leave a comment:


  • Aspin
    replied
    Originally posted by Zygor Support View Post
    Not sure how you got the Astrolabe folder in there. I'm looking at a fresh install of the guide files and the libs folder does not have the Astrolabe folder in there. Try manually deleting the ZygorGuidesViewer folder in the Addons folder then install a fresh copy of the guide files.
    I've done as you suggested, and Astrolabe is gone again. I'll check for errors next time I log in.

    As you'll see from above, I have done exactly this already today. The only change since then is the update from the previous version to 14859. Is it possible the updater is doing this for some reason, where it happens as part of an incremental update but Astrolabe isn't included in a full install?

    Leave a comment:


  • kupkakes11
    replied
    yes, twice. Ive also turned off all addons other than Zygor, still the same error

    Leave a comment:


  • Zygor Support
    replied
    Have you tried manually deleting the ZygorGuidesViewer folder (in the Addons folder) and installed a fresh copy of the guide files kupkakes?

    Leave a comment:


  • kupkakes11
    replied
    I've deleted my wtf folder, repaired the guide and reinstalled. Still receiving the following error:

    Message: ...ace\AddOns\ZygorGuidesViewer\Libs\UIDropDownFor k.lua:273: attempt to perform arithmetic on field 'numButtons' (a nil value)
    Time: 10/28/16 19:24:11
    Count: 2
    Stack: [C]: ?
    ...ace\AddOns\ZygorGuidesViewer\Libs\UIDropDownFor k.lua:273: in function `UIDropDownFork_AddButton'
    Interface\AddOns\ZygorGuidesViewer\Libs\EasyFork.l ua:30: in function `initFunction'
    ...ace\AddOns\ZygorGuidesViewer\Libs\UIDropDownFor k.lua:68: in function `UIDropDownFork_Initialize'
    Interface\AddOns\ZygorGuidesViewer\Libs\EasyFork.l ua:21: in function `EasyFork'
    ...rface\AddOns\ZygorGuidesViewer\ZygorGuidesViewe r.lua:4508: in function `OpenQuickStepMenu'
    ...rface\AddOns\ZygorGuidesViewer\ZygorGuidesViewe r.lua:3960: in function `GoalOnClick'
    ...dOns\ZygorGuidesViewer\Skins\Default\ViewerFram e.lua:311: in function <...dOns\ZygorGuidesViewer\Skins\Default\ViewerFra me.lua:310>
    ...dOns\ZygorGuidesViewer\Skins\Default\ViewerFram e.lua:35: in function <...dOns\ZygorGuidesViewer\Skins\Default\ViewerFra me.lua:27>

    Leave a comment:


  • Zygor Support
    replied
    Not sure how you got the Astrolabe folder in there. I'm looking at a fresh install of the guide files and the libs folder does not have the Astrolabe folder in there. Try manually deleting the ZygorGuidesViewer folder in the Addons folder then install a fresh copy of the guide files.

    Leave a comment:


  • Aspin
    replied
    Astrolabe seems to have made a reappearance in the latest update (6.0.14859), as have my errors while in instances. Was it intended for this to go back in?

    Leave a comment:


  • Aspin
    replied
    It's the only way to learn .

    Leave a comment:


  • Aspin
    replied
    Thanks for the info mate. It was mentioned earlier that Astrolabe was still used in a few places, but I guess it's been updated now. I wish I'd tried just dropping the addon folder first (it never occurred to me there would be differences) - enabling a hundred or so addons one at a time to test them is rather boring ;p.

    Leave a comment:


  • Zygor Support
    replied
    Originally posted by Aspin View Post
    You mentioned before that some components were still using it. Could you clarify whether that's still the case in the latest version (6.0.14846 as of now)? Otherwise I'm slightly confused :P.
    I thought that there were maybe one or two functions that still used it but apparently I was wrong. Sometimes it's good to be wrong.

    Leave a comment:

Working...
X