Page 4 of 9 FirstFirst ... 23456 ... LastLast
Results 31 to 40 of 83
  1. #31
    Quote Originally Posted by zgdev2 View Post
    Just for information. That's not a leak in any sense, and there's hard to even make one in Lua. Memory leak is when something allocated memory and doesn't give it back, so it would only grown more and more. We're actually trying to reproduce the issue, but I personally seem to be unable to get it happen in my setup yet.
    You mean like when the addon takes more and more memory until it crashes?
    --PvP Junkie--

  2. #32
    Quote Originally Posted by zgdev2 View Post
    Could you try using an OpenGL renderer for a change to see if that still happens?
    I just neither have a windows nor directx at all
    I am using all the recommended settings by blizzard. I don't mean to sound rude but I'm not comfortable changing things from what blizzard suggests to support an addon.
    --PvP Junkie--

  3. #33
    Ok so I continued troubleshooting and people kept mentioning ants off which really didn't help me find it. So I enclosed a screen shot for people because turning the feature off seemed to fix the issue. I also noticed if I just turn off the arrow it also fixes the issue but I am assuming that also in turn removes the ants.
    ants.jpg
    --PvP Junkie--

  4. #34
    Quote Originally Posted by sobeit81 View Post
    Ok so I continued troubleshooting and people kept mentioning ants off which really didn't help me find it. So I enclosed a screen shot for people because turning the feature off seemed to fix the issue. I also noticed if I just turn off the arrow it also fixes the issue but I am assuming that also in turn removes the ants.
    ants.jpg
    Just to add when I disable the ants from showing the leveling guide for farming pretty much becomes unusable because it no longer changes to the next path. This in itself may have something to do with the issue?

    Tried installing TomTom to see what would happen. It recognizes when I have a 1 point but not multiple points. I think the issue here is how the multiple points are being coded and translated. If TomTom isn't being shown the points then I am left to assume that multiple point locations are completely dependent on the ants. Which becomes a resource hog and lags things out and freezes it due to it doing all points at once rather than 1 by 1.
    --PvP Junkie--

  5. #35
    Administrator zgdev2's Avatar
    Join Date
    July 26th, 2011
    Posts
    147
    Update. We added a profiling system to the addon, which would hopefully allows us to track the issue down. It's being under development at the moment to ensure it's crashproof, so I'll comment in this thread in the next couple of days detailing how one can use it to pinpoint the problem.

    Quote Originally Posted by sobeit81 View Post
    I am using all the recommended settings by blizzard. I don't mean to sound rude but I'm not comfortable changing things from what blizzard suggests to support an addon.
    I did by no means to ask you change your settings, but for this bug to be resolved swiftly we need to be sure that it's the bug of Zygor itself and not the graphical subsystem of WoW. I don't presently have an option to test it in DirectX because my system.. doesn't have it at all. Once again, Zygor Guides neither do nor will require you to set something like this in order to use them, however, I was wondering if you could set it, tell if the problem persists, and set back to what settings your game uses right now.

    Quote Originally Posted by sobeit81 View Post
    Ok so I continued troubleshooting and people kept mentioning ants off which really didn't help me find it. So I enclosed a screen shot for people because turning the feature off seemed to fix the issue. I also noticed if I just turn off the arrow it also fixes the issue but I am assuming that also in turn removes the ants.
    Those two bugs seem to be separate. The ants only concern gathering professions guides.

    Quote Originally Posted by sobeit81 View Post
    You mean like when the addon takes more and more memory until it crashes?
    Precisely. I can't readily tell what would happen in WoW if an addon leaks, and moreover, I can't really imagine such thing happening with Lua's automatic memory management, but I think if it does happen, WoW just either restarts the Lua engine or suspends the addon in question. Either way, noticeable slowdowns because of high memory usages are only possible if your system is seriously starving, that is, as if Zygor took 200-300 Mb, which, supposedly is not the case.


    Quote Originally Posted by sobeit81 View Post
    Just to add when I disable the ants from showing the leveling guide for farming pretty much becomes unusable because it no longer changes to the next path. This in itself may have something to do with the issue?

    Tried installing TomTom to see what would happen. It recognizes when I have a 1 point but not multiple points. I think the issue here is how the multiple points are being coded and translated. If TomTom isn't being shown the points then I am left to assume that multiple point locations are completely dependent on the ants. Which becomes a resource hog and lags things out and freezes it due to it doing all points at once rather than 1 by 1.
    I guess they are separate as said above. However, ants slowdown have already been addressed in the past and it seems like a new bug with it. I wonder if you could detail it please?

  6. #36
    Quote Originally Posted by zgdev2 View Post
    I guess they are separate as said above. However, ants slowdown have already been addressed in the past and it seems like a new bug with it. I wonder if you could detail it please?
    Well I'm using the latest version of the guide. When I disable the ants the guide no longer moves to the next path selected for the herbalism guide unless it is to a specific location like the trainer. If I install TomTom it doesn't even recognize the paths for gather and only recognizes locations like visiting the trainer. So basically with ants off which is the only way to stop my lag the guide then will tell me to go to X route when I reach 0 (as I have reached the location) it just sits there. The only way to get it to go to the next path is to go back one step then back again to the collecting part. Not really sure how I was supposed to add more detail to something I thought I covered but I tried my best.

    As far as the OpenGL system I have access to Directx9 and Directx11 so in order to fill your request I would have needed to install and change settings.
    --PvP Junkie--

  7. #37
    daeymien's Avatar
    Join Date
    December 2nd, 2008
    Posts
    338
    Quote Originally Posted by sobeit81 View Post
    As far as the OpenGL system I have access to Directx9 and Directx11 so in order to fill your request I would have needed to install and change settings.
    To run WoW in OpenGL mode all you have to do is add the "-opengl" (minus quotes) switch to the run. See below.

    This


    becomes


    To go back to D3D afterwards, use -d3d

  8. #38
    Quote Originally Posted by daeymien View Post
    To run WoW in OpenGL mode all you have to do is add the "-opengl" (minus quotes) switch to the run. See below.

    This


    becomes


    To go back to D3D afterwards, use -d3d
    I went a head and made a shortcut since I use zygor guides as my launcher then did the steps to make it opengl and still have all the same issues I stated before. Has anything new been discovered with this at all? At this point all the guide does it to tell me when to train and I could have done that by looking at my professions window.

    If there is anything else I can try to do please give a detailed explanation of how and if I can do it I will.
    --PvP Junkie--

  9. #39
    I'll stop posting in this thread as I found this one in general discussion http://www.zygorguides.com/forum/sho...farming-routes that seems to some how get more response than the one in the Bug and Error thread and seems to be related to my issue. This forum has way to many spots and they all get posted to incorrectly I hate coming to the site purely for having to figure out where an issue is and hope to get help with it if need be.
    --PvP Junkie--

  10. #40
    Administrator zgdev2's Avatar
    Join Date
    July 26th, 2011
    Posts
    147
    Quote Originally Posted by sobeit81 View Post
    I'll stop posting in this thread as I found this one in general discussion http://www.zygorguides.com/forum/sho...farming-routes that seems to some how get more response than the one in the Bug and Error thread and seems to be related to my issue. This forum has way to many spots and they all get posted to incorrectly I hate coming to the site purely for having to figure out where an issue is and hope to get help with it if need be.
    I don't see ants in this equation yet, unfortunately, but the TomTom and Carbonite behaviour with gathering steps have been fixed and optimized. This seems to be unrelated to the main bug of this thread, though. I'm not quite ready to produce the instructions on how to catch it with newly-included CPU profiler, but it will follow soon.

Page 4 of 9 FirstFirst ... 23456 ... LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •