First of all, I want to thank you for all the help, I appreciate it and want to apologize for my incoming essay.

Okay, so I tried playing another character 20 lvl in Azhara. What I found is that it was working perfectly, whereas the area in the Night Elf zone 1-10 was not working properly(arrow disappearing). Maybe I do not know how the arrow works exactly? But my point is that the quests in Azhara and the quests in Teldrassil were of similar nature, a.k.a NPC are next to me, or I am in a place where I have to kill "8 hippogryphs" or whatever, but in Teldrassil the arrow kept disappearing when I approached not an nearby NPC, but the destination prior to the step where the arrow refocus and points toward the "center" of the blue zone in the map where a specific objective (NPC to kill, or things to gather are). Whereas, in an absolutely similar situation in Azshara, it worked perfectly(arrow NEVER disappeared). In teldrassil however, once I just did the quest anyways, without consulting the navigator and returned to give in the quest, again without the arrow pointing where to go, in the moved to the next step of the guide and reappeared only to disappear again in a similar fashion.

On one of the tests you told me to play without any other addons so as not to have interference, and I did, it still didn't fix the issue (in Teldrassil).

I am using the guide for 2 years on and off, this is the first time I noticed the arrow ever disappearing, and i also thought it would be universal(it wouldn't work in other areas as well.) But as I said, it worked perfectly when I tried it with another character in Azshara as of now.