Log in to ZYGOR
Log in with social media
OR
Log in with Zygor account
Forgot your password?

Announcement

Collapse
No announcement yet.

Leveling at Excile Reach throws LUA errors

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Leveling at Excile Reach throws LUA errors

    Hello

    When I level at Exile Reaches (Horde or Alliance), everytime I pick up or return quest it throws me this LUA:

    6x ...zzard_NewPlayerExperience\Blizzard_TutorialLogi c.lua:111: attempt to index field 'factionData' (a nil value)
    [string "@Blizzard_NewPlayerExperience\Blizzard_Tutori alLo gic.lua"]:111: in function `?'
    [string "@Blizzard_NewPlayerExperience\Blizzard_Tutori alQu estManager.lua"]:164: in function `_DoCallback'
    [string "@Blizzard_NewPlayerExperience\Blizzard_Tutori alQu estManager.lua"]:151: in function `SimulateEvents'
    [string "@Blizzard_NewPlayerExperience\Blizzard_Tutori alQu estManager.lua"]:173: in function `RegisterForCallbacks'
    [string "@Blizzard_NewPlayerExperience\Blizzard_Tutori alLo gic.lua"]:67: in function `Begin'
    [string "@Blizzard_NewPlayerExperience\Blizzard_Tutori al.l ua"]:40: in function `Begin'
    [string "@Blizzard_NewPlayerExperience\Blizzard_Tutori al.l ua"]:4: in function `Initialize'
    [string "@Blizzard_NewPlayerExperience\Blizzard_Tutori al.l ua"]:83: in main chunk
    [string "=[C]"]: ?
    [string "=[C]"]: in function `LoadAddOn'
    [string "@FrameXML\UIParent.lua"]:504: in function `UIParentLoadAddOn'
    [string "@FrameXML\UIParent.lua"]:760: in function `NPE_LoadUI'
    [string "@FrameXML\UIParent.lua"]:751: in function `NPE_CheckTutorials'
    [string "@FrameXML\UIParent.lua"]:821: in function `NPETutorial_AttemptToBegin'
    [string "@FrameXML\UIParent.lua"]:1656: in function <FrameXML\UIParent.lua:1277>

    Locals:
    self = <table> {
    Quest_Updated = <function> defined @Blizzard_NewPlayerExperience\Blizzard_TutorialLog ic.lua:162
    UPDATE_SHAPESHIFT_FORM = <function> defined @Blizzard_NewPlayerExperience\Blizzard_TutorialLog ic.lua:51
    Quest_Accepted = <function> defined @Blizzard_NewPlayerExperience\Blizzard_TutorialLog ic.lua:107
    PLAYER_LEVEL_CHANGED = <function> defined @Blizzard_NewPlayerExperience\Blizzard_TutorialLog ic.lua:7
    Quest_TurnedIn = <function> defined @Blizzard_NewPlayerExperience\Blizzard_TutorialLog ic.lua:165
    Begin = <function> defined @Blizzard_NewPlayerExperience\Blizzard_TutorialLog ic.lua:63
    Tutorials = <table> {
    }
    Shutdown = <function> defined @Blizzard_NewPlayerExperience\Blizzard_TutorialLog ic.lua:101
    CheckFormSpells = <function> defined @Blizzard_NewPlayerExperience\Blizzard_TutorialLog ic.lua:28
    Quest_ObjectivesComplete = <function> defined @Blizzard_NewPlayerExperience\Blizzard_TutorialLog ic.lua:144
    PLAYER_UNGHOST = <function> defined @Blizzard_NewPlayerExperience\Blizzard_TutorialLog ic.lua:24
    }
    questData = <table> {
    WasReinitializedAccepted = true
    Time_Accepted = 12032.800000
    QuestID = 2
    QuestTitle = "Klaue von Scharfkralle"
    class = <table> {
    }
    }
    questID = 2
    tutorials = <table> {
    UI_Watcher = <table> {
    }
    Intro_Chat = <table> {
    }
    Intro_KeyboardMouse = <table> {
    }
    DruidFormWatcher = <table> {
    }
    Intro_CombatTactics = <table> {
    }
    Death_ReleaseCorpse = <table> {
    }
    InventoryWatcher = <table> {
    }
    Intro_CameraLook = <table> {
    }
    AddMountToActionBar = <table> {
    }
    AddSpellToActionBarService = <table> {
    }
    Intro_OpenMap = <table> {
    }
    HunterStableWatcher = <table> {
    }
    Intro_CombatDummyInRange = <table> {
    }
    UseQuestItem = <table> {
    }
    LootCorpseWatcher = <table> {
    }
    PromptLFG = <table> {
    }
    UseMinimap = <table> {
    }
    Death_ResurrectPrompt = <table> {
    }
    Death_MapPrompt = <table> {
    }
    Intro_ApproachQuestGiver = <table> {
    }
    Death_Watcher = <table> {
    }
    ChangeSpec = <table> {
    }
    EnhancedCombatTactics_Warrior = <table> {
    }
    UseMount = <table> {
    }
    AutoPushSpellWatcher = <table> {
    }
    EatFood = <table> {
    }
    MountReceived = <table> {
    }
    EnhancedCombatTactics_Rogue = <table> {
    }
    LookingForGroup = <table> {
    }
    UseVendor = <table> {
    }
    HunterTame = <table> {
    }
    AddHunterTameSpells = <table> {
    }
    Intro_MapHighlights = <table> {
    }
    GossipFrameWatcher = <table> {
    }
    AbilityWatcher = <table> {
    }
    EnhancedCombatTactics_Ranged = <table> {
    }
    EnhancedCombatTactics_UseDoTs = <table> {
    }
    QuestCompleteHelp = <table> {
    }
    Intro_Interact = <table> {
    }
    AcceptQuestWatcher = <table> {
    }
    LeavePartyPrompt = <table> {
    }
    EnhancedCombatTactics = <table> {
    }
    ChangeEquipment = <table> {
    }
    TurnInQuestWatcher = <table> {
    }
    QuestRewardChoice = <table> {
    }
    ItemUpgradeCheckingService = <table> {
    }
    StealthWatcher = <table> {
    }
    Class_XPBarWatcher = <table> {
    }
    LowHealthWatcher = <table> {
    }
    }
    (*temporary) = nil
    (*temporary) = nil
    (*temporary) = nil
    (*temporary) = nil
    (*temporary) = "attempt to index field 'factionData' (a nil value)"


    No other Addons enabled. When I disable Zygor, I get no LUA errors.

    #2
    Try doing a full guide reset.

    1. exit WoW
    2. go to the WoW/_retail_/Interface/Addons folder and delete the ZygorGuidesViewer folder
    3. go to the WoW/_retail_/WTF/Account/<your account name here>/SavedVariables folder and delete the Zygor files in there
    4. run the desktop client and install a fresh copy of the guides
    5. go back in game to test and let me know if that fixed it
    Become a Fan of Zygor Guides on Facebook:
    http://www.facebook.com/pages/Zygor-...04933799556988

    Follow Zygor Guides on Twitter:
    http://twitter.com/zygorguides

    Comment


      #3
      The error suggests it's on Blizzard's end. There's no mention of Zygor. Does the error reliably show up and disappear over and over when disabling or enabling our addon?
      Zygor Guides Creative Director

      Comment


        #4
        Yes the LUA error only happend when I enabled Zygor.
        I deleted WTF, Cache and that Blob folder and that somehow solved the issue. Only deleted WTF before which didnt help so must have been something else.

        Thanks :-)

        Comment

        Working...
        X