Log in to ZYGOR
Log in with social media
OR
Log in with Zygor account
Forgot your password?

Announcement

Collapse
No announcement yet.

Battle Pet Questline

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Battle Pet Questline

    Step 49 - Click the complete quest box on the right side of your screen
    Turned in 'Battle Pet Tamers: Outland'
    Accepted 'Grand Master Antari'

    Step 50 - goto Jade Forest and level pets to 25

    Step 51 - Go to 30,42
    Talk to Bloodknight Antari....
    Let's fight! .... Your pets should be around lvl 24

    I thought It skipped alot at first and it took me awhile before it hit me to move from step 50 to 51 to see what it says, but the way it reads Bloodknight Antari is in Jade Forest in Pandaria instead of in Shadowmoon Valley or to even head in that direction. It's also the reason I found and necro'd the 3-4 month thread about Kalimdor where the guide completely skips that line of quests (No Achievement for Kalimdor that I can see)

    #2
    The arrow should be directing you to Shadowmoon Valley.

    I can see the line in the guide file: goto Shadowmoon Valley 30.6,42.0

    Are you using the travel system and our arrow? Double check all of those settings.

    As for the Kalimdor line, as I explained in the previous post (in the other thread) those can only be done on a Horde toon using the Horde guide, that's how Blizzard designed it. We have no control over that.
    My Flight Path Follies guide

    A pessimist knows all women are bad... an optimist hopes they are.

    I reject your reality and substitute my own.

    All foreign languages are done with Google Translate.

    Comment

    Working...
    X